Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   SuperDuper! & FileVault 2 in Mountain Lion (

Vlad Ghitulescu 10-16-2012 05:30 PM

SuperDuper! & FileVault 2 in Mountain Lion

I have a question regarding FileVault and SuperDuper!

Yesterday I had encrypted the whole internal disk of my iMac (running Mountain Lion) using FileVault 2.
After this I started SuperDuper! in order to update - with Smart Update - my backup. Everything went fine!

I wanted to test the encryption, so I plugged the external backup-drive to a MacBook Pro. To my surprise I got access to the whole content of the cloned iMac without any password!

Did I misunderstood FileVault? I thought it wouldn't allow the access. Or is this true only for the original (iMac) and not for the clone (backup)?

Or is it the backup with Smart Update that doesn't allow to the encryption to work?

Thanks for any hint!

Kind regards,

dnanian 10-16-2012 05:32 PM

You didn't format the backup drive with encryption. Do so, then back up to it with Smart Update.

Vlad Ghitulescu 10-16-2012 05:46 PM

encrypted drive!
Thanks, Dave! I'll encrypt the disk and try again.

One question regarding encryption. I would like to create an encrypted sparse bundle with Knox on the backup drive rather than encrypt the backup drive with Disk Utility due to the fact that Disk Utility doesn't allow to paste passwords.

Is it possible to use SuperDuper! to backup the iMac to this encrypted sparse bundle?

Thanks again!


dnanian 10-16-2012 05:50 PM

I don't see why not. You'll have to point is at the mounted bundle (the volume).

Vlad Ghitulescu 10-16-2012 06:03 PM

I'll test...
... and report the results.

Thanks again for your support!

Kind regards,

Vlad Ghitulescu 10-28-2012 02:23 AM

everything is fine!

I have tested the suggested solution (external disk formatted as encrypted sparse bundle, then used for backup - with SuperDuper! and SmartUpdate - for a FileVault-encrypted internal disk) and it works just fine!

Thanks again!

Kind regards,

dnanian 10-28-2012 07:51 AM

Glad to hear it worked as expected.

Vlad Ghitulescu 12-28-2012 10:19 PM

unable to restart from the encrypted backup

A (late!) follow-up to the above discussion: I am not able to restart from the encrypted backup-drive! :-(

Restarting the iMac while holding down the Option key shows in the Startup Manager my internal drive and the encrypted backup-drive. However choosing the encrypted backup-drive does leads to nothing: the system does not boot! I've got the same behavior also when choosing the backup-drive from the system preferences' Startup Drive section.

Everything is backup-ed on the drive (I have access to the data on the drive after entering the password) but I am not able to restart from it.

Do you have an idea?

Thank you!


dnanian 12-28-2012 10:27 PM

Repair the backup drive with Disk utility (running from the regular drive, using the right-hand "repair disk" button, NOT repair permissions). Then, select it in the startup disk preference pane as the startup drive. Does that work?

Vlad Ghitulescu 12-28-2012 10:35 PM

already done with DiskWarrior

Thank you for your quick reply.

I had already repaired the backup-drive using DiskWarrior.

I will try this again with Disk utility as suggested and post the results.

Thanks again!


dnanian 12-28-2012 10:39 PM

Also make sure you try to start up using the Startup Disk preference pane.

Vlad Ghitulescu 12-28-2012 11:13 PM

it still doesn't :-(

I have repaired the backup-drive with the Disk utility. The drive was reported to be ok.

After this I have restarted using the Startup Disk preference pane. I was presented with the Startup screen and two (!) user: a Guest-account and another one labeled "[updated needed]".

Restarting while holding down the Option key changes nothing.

What to do?


P.S. I forgot to tell that I had also set a firmware password.

dnanian 12-29-2012 08:56 AM

If you overwrite this backup with a regular, non-encrypted backup (do an erase-then-copy), does it work as expected?

Vlad Ghitulescu 12-30-2012 07:25 AM

no restart from EFI Boot
Hello, Dave!

I want to report the current status: I have first tried an erase-then-copy on the encrypted backup-drive. After 12 hours the backup was ready.

Restarting from the encrypted backup-drive was however not possible.

Restarting using the Startup Disk preference pane put the mac in a waiting loop: nothing happened after the white/grey screen!

Restarting while holding down the Option key shows the following bootable drives: the internal drive, EFI-Boot and the TimeMachine-drive.

Choosing the EFI-Boot shows Startup screen and the two user described below (a Guest-account and another one labeled "[updated needed]").

I will now delete the Backup-drive and partition it as (simple, not encrypted) Mac OS X (Journaled). After this I will start again an erase-then-copy, try to restart from it and report the status again.

Until then,

P.S. I am still very suspicious about the firmware-password. Right now I am not able to restart in the recovery partition (see also my question in an Apple-discussions-forum), I am not able to reset the NVRAM and I am not able to make a safe reboot (due to FileVault2). I don't know if all this has something to do with my question here, but it address at least the same strange behavior after reboot.

dnanian 12-30-2012 09:08 AM

You are also not able to start up to your local recovery volume? Perhaps you should try removing the firmware password?

All times are GMT -4. The time now is 05:24 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.